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NI myDAQ is a low-cost portable data acquisition (DAQ) device that uses NI LabVIEW-based
software instruments, allowing students to measure and analyze real-world signals. NI myDAQ
is ideal for exploring electronics and taking sensor measurements. Combined with NI LabVIEW
on the PC, students can analyze and process acquired signals and control simple processes
anytime, anywhere.
Figure 1. NI myDAQ
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Safety Information
Do not operate the hardware in a manner not specified in this document
and in the user documentation. Misuse of the hardware can result in a hazard. You
can compromise the safety protection if the hardware is damaged in any way. If the
hardware is damaged, return it to National Instruments for repair.

Caution

Clean the hardware with a soft, nonmetallic brush. Make sure that the hardware is completely
dry and free from contaminants before returning it to service.
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Electromagnetic Compatibility Guidelines
Cautions

To ensure the specified EMC performance:

•

The USB cable must be less than 2.0 m (6.6 ft) in length.

•

The length of any wire or cable connected to the 20-pin screw terminal
connector must be no longer than 0.3 m (1 ft).

•

The length of any wire or cable connected to the Audio or DMM ports must be
no longer than 3 m (10 ft).

This product was tested and complies with the regulatory requirements and limits for
electromagnetic compatibility (EMC) as stated in the product specifications. These requirements
and limits are designed to provide reasonable protection against harmful interference when the
product is operated in its intended operational electromagnetic environment.
This product is intended for use in residential, commercial, and industrial locations. There is no
guarantee that harmful interference will not occur in a particular installation or when the product
is connected to a test object. To minimize the potential for the product to cause interference to
radio and television reception or to experience unacceptable performance degradation, install
and use this product in strict accordance with the instructions in the product documentation.
Furthermore, any changes or modifications to the product not expressly approved by National
Instruments could void your authority to operate it under your local regulatory rules.

NI myDAQ Hardware Overview
NI myDAQ provides analog input (AI), analog output (AO), digital input and output (DIO),
audio, power supplies, and digital multimeter (DMM) functions in a compact USB device.
Tip The Common Terms and Acronyms section has a list of acronyms and terms
that you will see in this manual, and in many engineering and measurement
documents and websites.
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Integrated circuits supplied by Texas Instruments form the power and analog I/O subsystems of
NI myDAQ. Figure 2 depicts the arrangement and function of the NI myDAQ subsystems. Refer
to Table 5 for more information on all of the Texas Instruments components used in NI myDAQ.
Figure 2. NI myDAQ Hardware Block Diagram
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Note: NI myDAQ components may be changed or substituted without notice.

Analog Input (AI)
There are two analog input channels on NI myDAQ. These channels can be configured either as
general-purpose high-impedance differential voltage input or audio input. The analog inputs are
multiplexed, meaning a single analog-to-digital converter (ADC) is used to sample both
channels. In general-purpose mode, you can measure up to ±10 V signals. In audio mode, the
two channels represent left and right stereo line level inputs. Analog inputs can be measured at
up to 200 kS/s per channel, so they are useful for waveform acquisition. Analog inputs are used
in the NI ELVISmx Oscilloscope, Dynamic Signal Analyzer, and Bode Analyzer instruments.
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Analog Output (AO)
There are two analog output channels on NI myDAQ. These channels can be configured as either
general-purpose voltage output or audio output. Both channels have a dedicated
digital-to-analog converter (DAC), so they can update simultaneously. In general-purpose
mode, you can generate up to ±10 V signals. In audio mode, the two channels represent left and
right stereo outputs.
Caution If using earphones to listen to the audio output of the NI myDAQ, ensure
that the volume is set to a safe level. Listening to audio signals at a high volume may
result in permanent hearing loss.
Note The myDAQ supports output on either a ±10 V or ±2 V range and output
from either one or both AO channels. When outputting from both AO channels,
however, they must share a common voltage range.

Creating a task on an AO channel will set the range for both channels. If
a task that was previously running is stopped and a new task is created using the
second AO channel set to a different output range, the output on the original channel
will scale based on the range of the new task.
Caution

Analog outputs can be updated at up to 200 kS/s per channel, making them useful for waveform
generation. Analog outputs are used in the NI ELVISmx Function Generator, Arbitrary
Waveform Generator, and Bode Analyzer instruments.

Digital Input/Output (DIO)
There are eight DIO lines on NI myDAQ. Each line is a Programmable Function Interface (PFI),
meaning that it can be configured as a general-purpose software-timed digital input or output, or
it can act as a special function input or output for a digital counter. Refer to Digital I/O (DIO)
and Counters/Timers section for more information about the counter on NI myDAQ.
Note The digital I/O lines are 3.3 V LVTTL and are tolerant to 5 V inputs. The
digital output is not compatible with 5 V CMOS logic levels.

Power Supplies
There are three power supplies available for use on NI myDAQ. +15 V and -15 V can be used
to power analog components such as operational amplifiers and linear regulators. +5 V can be
used to power digital components such as logic devices.
The total power available for the power supplies, analog outputs, and digital outputs is limited
to 500 mW (typical)/100 mW (minimum). To calculate the total power consumption of the
power supplies, multiply the output voltage by the load current for each voltage rail and sum
them together. For digital output power consumption, multiply 3.3 V by the load current. For
analog output power consumption, multiply 15 V by the load current. Using audio output
subtracts 100 mW from the total power budget.
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For example, if you use 50 mA on +5 V, 2 mA on +15 V, 1 mA on -15 V, use four DIO lines to
drive LEDs at 3 mA each, and have a 1 mA load on each AO channel, the total output power
consumption is:
5 V × 50 mA = 250 mW
|+15 V| × 2 mA = 30 mW
|-15 V| × 1 mA = 15 mW
3.3 V × 3 mA × 4 = 39.6 mW
15 V × 1 mA × 2 = 30 mW
Total output power consumption = 250 mW + 30 mW + 15 mW + 39.6 mW +
30 mW = 364.6 mW

Digital Multimeter (DMM)
The NI myDAQ DMM provides the functions for measuring voltage (DC and AC), current
(DC and AC), resistance, and diode voltage drop.
DMM measurements are software-timed, so update rates are affected by the load on the
computer and USB activity.

NI myDAQ Software Overview
NI ELVISmx Driver Software
NI ELVISmx is the driver software that supports NI myDAQ. NI ELVISmx uses
LabVIEW-based software instruments to control the NI myDAQ device, providing the
functionality of a suite of common laboratory instruments. Refer to the Using NI myDAQ with
NI ELVISmx Software Instruments section for information on the NI ELVISmx suite of
measurement instruments.
NI ELVISmx is located on your driver software installation media included in the NI myDAQ
kit, or can be found by searching for ELVISmx on the Drivers and Updates page at ni.com/
drivers. To determine the version of NI ELVISmx software support required for your version
of LabVIEW, go to ni.com/info and enter the Info Code ELVISmxsoftware.

NI LabVIEW and NI ELVISmx Express VIs
Also installed with NI ELVISmx are the LabVIEW Express VIs, which use NI ELVISmx
software instruments to program NI myDAQ with more enhanced functionality. For more
information on the NI ELVISmx Express VIs, refer to the Using NI myDAQ with LabVIEW
section.
Note NI ELVISmx supports LabVIEW (32 bit). To use NI ELVISmx with
LabVIEW on a 64-bit operating system, you must have LabVIEW (32 bit) installed.
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NI myDAQ and NI Multisim
You can use NI ELVISmx instruments in NI Multisim to simulate a circuit, measure the real
signals with NI myDAQ, and compare simulated and acquired data. For more information on the
features and resources available with NI Multisim, visit ni.com/multisim.

Getting Started
Getting started with NI myDAQ is a simple process, but it is important to ensure that you install
the right components in the correct order. To get started with your NI myDAQ, complete the
following steps:
1.

Install the NI myDAQ Software Suite from the DVD shipped with your device.
The NI myDAQ Software Suite installs application software (NI LabVIEW, NI Multisim)
first, and then installs the NI ELVISmx driver software.
Note If you are not installing software from the NI myDAQ Software Suite media,
make sure to install all application software before installing the driver software.

2.

Connect the cable from the computer Hi-Speed USB port to the USB port on the device.
The computer will recognize the NI myDAQ and the NI ELVISmx Instrument Launcher
appears. You can also manually open NI ELVISmx Instrument Launcher by selecting
Start»All Programs»National Instruments»NI ELVISmx for NI ELVIS &
NI myDAQ»NI ELVISmx Instrument Launcher.
To ensure the specified EMC performance, the USB cable must be less
than 2.0 m (6.6 ft) in length.

Caution

Making Signal Connections with NI myDAQ
Setting up Your NI myDAQ Device
Caution Insert and remove the 20-position screw terminal connector aligned
evenly to the NI myDAQ. Inserting the screw terminal connector at an angle to the
NI myDAQ may cause damage to the connector.

The screw terminal connector must snap securely into place to ensure proper signal
connection.
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Figure 3. NI myDAQ Connection Diagram
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20-Position Screw Terminal Connector
Audio Cable
DMM Banana Cable

Connecting Signals
Figure 4 shows the available audio, AI, AO, DIO, GND, and power signals accessed through the
3.5 mm audio jacks and screw terminal connections. Refer to Table 1 for descriptions of these
signals.
Signal wires must be securely affixed and screwed down in the screw
terminal connector to ensure proper connection.

Cautions

To ensure the specified EMC performance:
•

The length of any wire or cable connected to the 20-pin screw terminal
connector must be no longer than 0.3 m (1 ft).

•

The length of any wire or cable connected to the Audio or DMM ports must be
no longer than 3 m (10 ft).

DIO 0/PFI 0/CTR 0 SOURCE
DIO 1/PFI 1/CTR 0 GATE
DIO 2/PFI 2/CTR 0 AUX
DIO 3/PFI 3/CTR 0 OUT
DIO 4/PFI 4/FREQ OUT

Figure 4. NI myDAQ 20-Position Screw Terminal I/O Connector

AUDIO
IN

AUDIO
OUT

Table 1. Screw Terminal Signal Descriptions

Signal Name

Reference

Direction

AUDIO IN

—

Input

AUDIO OUT

—

Output

Audio Output—Left and right audio
outputs on a stereo connector

AGND

Output

+15 V/-15 V power supplies

—

—

AO 0/AO 1

AGND

Output

AI 0+/AI 0-;
AI 1+/AI 1-

AGND

Input

+15V/-15V
AGND

Description

Audio Input—Left and right audio
inputs on a stereo connector

Analog Ground—Reference terminal
for AI, AO, +15 V, and -15 V
Analog Output Channels 0 and 1*
Analog Input Channels 0 and 1
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Table 1. Screw Terminal Signal Descriptions (Continued)

Signal Name

Reference

Direction

DGND

Input or
Output

DGND

—

—

Digital Ground—Reference for the DIO
lines and the +5 V supply

PFI 0/
CTR 0 SOURCE

—

—

Digital I/O, line 0; PFI 0, Default
function: Counter 0 Source

PFI 1/
CTR 0 GATE

—

—

Digital I/O, line 1; PFI 1, Default
function: Counter 0 Gate

PFI 2/
CTR 0 AUX

—

—

Digital I/O, line 2; PFI 2, Default
function: Counter 0 Aux

PFI 3/
CTR 0 OUT

—

—

Digital I/O, line 3; PFI 3, Default
function: Counter 0 Out

PFI 4/
FREQ OUT

—

—

Digital I/O, line 4; PFI 4, Default
function: Frequency Output

DGND

Output

DIO <0..7>

5V

Description

Digital I/O Signals—General-purpose
digital lines or counter signals

5 V power supply

* The myDAQ supports output on either a ±10 V or ±2 V range and output from either one or both AO channels.

When outputting from both AO channels, however, they must share a common voltage range.

Figure 5 shows the DMM connections on the NI myDAQ. Table 2 describes these signals.
60 VDC/20 Vrms maximum. Do not plug digital multimeter probes into
circuits with Hazardous Voltages, such as wall outlets.
Caution

Figure 5. Connections for DMM Measurements
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Table 2. DMM Signal Descriptions

Signal
Name

Reference

Direction

COM

Input

COM

—

—

HI (A)

COM

Input

HI (VΩ

)

Description

Positive terminal for voltage, resistance,
and diode measurements
Reference for all DMM measurements
Positive terminal for current measurements
(Fused: F 1.25 A 250 V Fast-Acting)

Connecting Analog Input Signals
When configuring the input channels and making signal connections, you must first determine
whether the signal sources are floating or ground referenced. The following sections describe
these two signal types.

Ground-Referenced Signal Sources
A ground-referenced signal source is connected to the building system ground, so it is already
connected to a common ground point with respect to the NI myDAQ device, assuming that the
computer is plugged into the same power system. Instruments or devices with nonisolated
outputs that plug into the building power system are ground-referenced signal sources.
Note Most laptop computers have isolated power supplies, and are consequently
not connected to the building ground system. In these cases, treat the analog input
signal as floating with respect to NI myDAQ.

The difference in ground potential between two instruments connected to the same building power
system is typically between 1 and 100 mV. This difference can be much higher if power
distribution circuits are improperly connected. If a grounded signal source is improperly measured,
this difference might appear as a measurement error. Connect the differential analog inputs across
the signal source and do not connect the NI myDAQ AGND pin to the grounded source.
Figure 6. Ground-Referenced Differential Connection
Signal Source
AI+
+
–

AI–

+
–
AGND
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Floating Signal Sources
A floating signal source is not connected to the same ground reference as NI myDAQ, but
instead has an isolated reference point. Some examples of floating signal sources are
battery-powered devices, outputs of transformers, thermocouples, optical isolator outputs, and
isolation amplifiers. An instrument or device that has an isolated output is a floating signal
source. You must connect the ground reference of a floating signal to an NI myDAQ AGND pin
through a bias resistor or jumper wire to establish a local or onboard reference for the signal.
Otherwise, the measured input signal varies as the source floats out of the common-mode input
range.
The easiest way to reference the source to AGND is to connect the positive side of the signal to
AI+ and connect the negative side of the signal to AGND as well as to AI- without using
resistors. This connection works well for DC-coupled sources with low source impedance (less
than 100 Ω).
Figure 7. Differential Connections for Floating Signal Sources without Resistors
Signal Source
AI+

+
–

AI–

Rsource >100 Ω

+
–
AGND

For larger source impedances, however, this connection leaves the differential signal path
significantly off balance. Noise that couples electrostatically onto the positive line does not
couple onto the negative line because it is connected to ground. This noise appears as a
differential-mode signal instead of a common-mode signal, and thus appears in your data. In this
case, instead of directly connecting the negative line to AGND, connect the negative line to
AGND through a resistor that is about 100 times the equivalent source impedance. The resistor
puts the signal path nearly in balance, so that about the same amount of noise couples onto both
connections, yielding better rejection of electrostatically coupled noise. This configuration does
not load down the source.
Figure 8. Differential Connections for Floating Signal Sources with a Single Resistor
Signal Source
AI+
+
–
Rsource >100 Ω
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AI–

+
–
AGND

You can fully balance the signal path by connecting another resistor of the same value between
the positive input and AGND, as shown in Figure 9. This fully balanced configuration offers
slightly better noise rejection, but has the disadvantage of loading the source down with the
series combination (sum) of the two resistors. If, for example, the source impedance is 2 kΩ and
each of the two resistors is 100 kΩ, the resistors load down the source with 200 kΩ and produce
a -1% gain error.
Figure 9. Differential Connections for Floating Signal Sources with Two Resistors
Signal Source
AI+
+
–

AI–

Rsource >100 Ω

+
–
AGND

Both positive and negative analog input lines require a DC path to ground in order for the
instrumentation amplifier to work. If the source is AC coupled (capacitively coupled), a resistor
is needed between the positive input and AGND. If the source has low impedance, choose a
resistor that is large enough not to significantly load the source but small enough not to produce
significant input offset voltage as a result of input bias current (typically 100 kΩ to 1 MΩ). In
this case, connect the negative input directly to AGND. If the source has high output impedance,
balance the signal path as previously described using the same value resistor on both the positive
and negative inputs.

NI myDAQ DMM Fuse Replacement
NI myDAQ has a fuse to protect the device from overcurrent through HI (A) current
measurement input on the DMM. If the NI ELVISmx DMM software instrument always reads
0 A current, the cause may be a blown fuse.

Testing Your Fuse
To test for a blown fuse, complete the following steps.
1.

Using a banana cable, connect the HI (V) and HI (A) DMM terminals.

2.

Launch the NI ELVISmx Digital Multimeter (DMM) software instrument from the
NI ELVISmx Instrument Launcher, located at Start»All Programs»National
Instruments»NI ELVISmx for NI ELVIS & NI myDAQ»NI ELVISmx Instrument
Launcher.

3.

Select the Resistance mode by clicking the Resistance button

.

4.

Click Run.

5.

If the fuse is blown, the display will show +Over, indicating a disconnected circuit path.
Replace the fuse and complete the procedure again.

NI myDAQ User Guide
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Replacing the Fuse
Replace broken fuses with a 1.25 A Fast-Acting sand-filled 5 × 20 mm fuse (Littelfuse part
number 02161.25 at www.littelfuse.com).
To replace a broken fuse, complete the following steps.
1.

Power down the device by properly disconnecting it from the PC and removing the USB
cable.

2.

Remove the screw terminal connector and all other signal cables from the device.

3.

Loosen the four Phillips screws that attach the bottom of the enclosure to the device, and
remove the top lid of the enclosure.
Caution

Do not remove the board from the bottom half of the NI myDAQ

enclosure.
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4.

Replace the broken fuse while referring to Figure 10 for the fuse location, taking care to not
damage any components on the board.
Figure 10. NI myDAQ Fuse Location
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Replace the lid and screws.
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Digital I/O (DIO) and Counters/Timers
There are eight, software-timed DIO lines on the NI myDAQ that can be individually configured
for input or output. Additionally, lines DIO <0..4> can be configured for counter/timer
functionality. The input—accessed through DIO 0, DIO 1, and DIO 2 signals configured as a
counter—is used for counter, timer, pulse width measuring, and quadrature encoding
applications.
When using the counter/timer, the Source is accessed through DIO 0, the Gate through DIO 1,
the Auxiliary Input through DIO 2, the Output through DIO 3, and the Frequency Output
through DIO 4. When using the counter/timer as a quadrature encoder, A, Z, and B correspond
to DIO 0, DIO 1, and DIO 2, respectively. In some instances, the software may refer to the
output lines as PFI as opposed to DIO. Refer to Table 3 for a list of the corresponding
counter/timer signals assignments through the DIO terminals.
Table 3. NI myDAQ Counter/Timer Signal Assignments

NI myDAQ
Signal

Programmable
Function Interface
(PFI)

Counter/Timer
Signal

Quadrature Encoder
Signal

DIO 0

PFI 0

CTR 0 SOURCE

A

DIO 1

PFI 1

CTR 0 GATE

Z

DIO 2

PFI 2

CTR 0 AUX

B

DIO 3*

PFI 3

CTR 0 OUT

—

DIO 4

PFI 4

FREQ OUT

—

*

DIO 3 can be used to generate pulse-width modulation (PWM) signals.

For more information about event timing requirements, refer to the NI myDAQ Specifications
document. For more detailed information on using counter/timers with NI myDAQ, refer to the
KnowledgeBase document How Do I Use the NI myDAQ Counter?. To access this document,
go to ni.com/info and enter the Info Code mydaqcounter.

Using NI myDAQ with NI ELVISmx Software
Instruments
Before opening an NI ELVISmx software instrument, make sure that the
myDAQ device is connected to the system and is ready to use. After the myDAQ is
connected to the system, the blue LED by the connector lights, indicating the device
is ready for use. The NI ELVISmx Instrument Launcher then launches automatically.
Note
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NI ELVISmx provides a collection of software instruments, created in LabVIEW, and the source
code for the instruments. You cannot directly modify the executable files, but you can modify or
enhance the functionality of these instruments by modifying the LabVIEW code, which installs
in the following directory: C:\Users\Public\Public Documents\National
Instruments\NI ELVISmx Source Code

For a detailed explanation of the NI ELVISmx software instruments,
instructions for taking a measurement with each instrument, and information on the
other NI ELVISmx Instrument Launcher features, refer to the NI ELVISmx Help. To
access this help file, click the NI ELVISmx Help icon on the Resources tab of the
NI ELVISmx Instrument Launcher.

Note

NI ELVISmx Instrument Launcher
The NI ELVISmx Instrument Launcher provides access to the NI ELVISmx software
instruments, additional featured instruments, lab exercises, documentation and online resource
links, and functionality to add data and reference files. To open the Instrument Launcher,
navigate to Start»All Programs»National Instruments»NI ELVISmx for NI ELVIS &
NI myDAQ»NI ELVISmx Instrument Launcher. This opens the suite of NI ELVISmx
software instruments.
Figure 11. NI ELVISmx Instrument Launcher

To launch an instrument, click the button corresponding to the desired instrument. Select the
NI myDAQ device from the Device control pull-down dialog.
Some instruments perform similar operations using the same resources of the NI myDAQ
hardware and therefore cannot run at the same time. If you launch two instruments with
overlapping functionality that cannot run at the same time, the NI ELVISmx software generates
an error dialog describing the conflict. The instrument with the error is disabled and will not
function until the conflict is resolved. For information about possible resource conflicts, refer to
the Resource Conflicts section.
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Digital Multimeter (DMM)
The NI ELVISmx Digital Multimeter (DMM) is a stand-alone instrument that controls the basic
DMM capabilities of NI myDAQ. This commonly used instrument can perform voltage
measurements (DC and AC), current measurements (DC and AC), resistance measurements,
diode tests, and audible continuity tests.
If the DMM panel displays OVER+ during a measurement, this indicates an
overvoltage condition or other possible error. Some instances require you to reset the
configuration data in NI Measurement & Automation Explorer (MAX). Refer to
ni.com/info and enter the Info Code exhed4 for infomation on how to reset your
MAX configuration data.
Note

Make connections for measurements to the DMM banana jacks on the device. This instrument
has the following measurement parameters:
•

DC voltage: 60 V, 20 V, 2 V, and 200 mV ranges

•

AC voltage: 20 V, 2 V, and 200 mV ranges

•

DC current: 1 A, 200 mA, and 20 mA ranges

•

AC current: 1 A, 200 mA, and 20 mA ranges

•

Resistance: 20 MΩ, 2 MΩ, 200 kΩ, 20 kΩ, 2 kΩ, and 200 Ω ranges

•

Diode: 2 V range

•

Resolution (number of significant digits for display): 3.5
Figure 12. NI ELVISmx Digital Multimeter
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Oscilloscope (Scope)
The NI ELVISmx Oscilloscope (Scope) displays voltage data for analysis. This instrument
provides the functionality of the standard desktop oscilloscope found in typical undergraduate
laboratories. The NI ELVISmx Oscilloscope has two channels and provides scaling and position
adjustment knobs along with a modifiable timebase. The autoscale feature allows you to adjust
the voltage display scale based on the peak-to-peak voltage of the AC signal for the best display
of the signal.
The computer-based scope display has the ability to use cursors for accurate screen
measurements. This instrument has the following measurement parameters:
•

Channel Source: Channels AI 0 and AI 1; AudioInput Left, and AudioInput Right. You can
use AI channels or AudioInput channels, but not a combination of both.

•

Coupling: AI Channels support DC Coupling only. AudioInput Channels support
AC Coupling only.

•

Scale Volts/Div: AI channels—5 V, 2 V, 1 V, 500 mV, 200 mV, 100 mV, 50 mV, 20 mV,
10 mV and for AudioInput Channels—1 V, 500 mV, 200 mV, 100 mV, 50 mV, 20 mV,
10 mV.

•

Sample Rate: The Max Sample Rate available for AI and AudioInput Channels: 200 kS/s
when either one or both channels are configured.

•

Timebase Time/Div: The available values for both AI and AudioInput channels: 200 ms
to 5 µs.

•

Trigger settings: Immediate and Edge Trigger Types are supported. When using Edge
Trigger Type, you can specify a Horizontal Position of 0% to 100%.
Figure 13. NI ELVISmx Oscilloscope
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Function Generator (FGEN)
The NI ELVISmx Function Generator (FGEN) generates standard waveforms with options for
the type of output waveform (sine, square, or triangle), amplitude selection, and frequency
settings. In addition, the instrument offers DC offset setting, frequency sweep capabilities, and
amplitude and frequency modulation. The FGEN uses AO 0 or AO 1 on the screw terminal
connector.
This instrument has the following measurement parameters:
•

Output channel: AO 0 or AO 1

•

Frequency range: 0.2 Hz to 20 kHz
Figure 14. NI ELVISmx Function Generator
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Bode Analyzer
The NI ELVISmx Bode Analyzer produces a Bode plot for analysis. By combining the
frequency sweep feature of the function generator and the analog input capability of the device,
a full-function Bode Analyzer is available with NI ELVISmx. You can set the frequency range
of the instrument and choose between linear and logarithmic display scales. You can also invert
the measured values of the input signal during Bode analysis by inverting the Op-Amp signal
polarity. Refer to the NI ELVISmx Help for required hardware connections. To access this help
file, go to Start»All Programs»National Instruments»NI ELVISmx for NI ELVIS &
NI myDAQ»NI ELVISmx Help.
This instrument has the following measurement parameters:
•

Stimulus measurement channel: AI 0

•

Response measurement channel: AI 1

•

Stimulus signal source: AO 0

•

Frequency range: 1 Hz to 20 kHz
Figure 15. NI ELVISmx Bode Analyzer
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Dynamic Signal Analyzer (DSA)
The NI ELVISmx Dynamic Signal Analyzer (DSA) performs a frequency domain transform of
the AI or Audio Input waveform measurement. It can either continuously make measurements
or make a single scan. You can also apply various window and filtering options to the signal.
This instrument has the following measurement parameters:
•

Source Channel: AI 0 and AI 1; AudioInput Left and AudioInput Right

•

Voltage Range:
–

For AI channels: ±10 V, ±2 V

–

For AudioInput channels: ±2 V
Figure 16. NI ELVISmx Dynamic Signal Analyzer
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Arbitrary Waveform Generator (ARB)
The NI ELVISmx Arbitrary Waveform Generator (ARB) generates a signal, displayed as an
electrical waveform. This advanced-level software instrument uses the AO capabilities of the
device. You can create a variety of signal types using the Waveform Editor software, which
is included with the NI ELVISmx software. You can load waveforms created with the
NI Waveform Editor into the NI ELVISmx ARB to generate stored waveforms. Refer to the
NI ELVISmx Help for more information about the Waveform Editor. To access this help file, go
to Start»All Programs»National Instruments»NI ELVISmx for NI ELVIS & NI myDAQ»
NI ELVISmx Help.
Since the device has two AO and two AudioOutput channels, two waveforms may be
simultaneously generated. You can choose to run continuously or run once. This instrument has
the following measurement parameters:
•

Output Channels: AO 0 and AO 1; AudioOutput Left and AudioOutput Right. You can use
AO channels or AudioOutput channels, but not a combination of both.

•

Trigger Source: Immediate only. This control will always be disabled.
Figure 17. NI ELVISmx Arbitrary Waveform Generator
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Digital Reader
The NI ELVISmx Digital Reader reads digital data from the NI myDAQ digital lines.
NI ELVISmx Digital Reader groups the I/O lines into ports through which data can be read. You
can read one port at a time, either continuously or as a single reading. The lines are grouped into
two ports of four pins (0 to 3 and 4 to 7) or one port of eight pins (0 to 7).
Figure 18. NI ELVISmx Digital Reader
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Digital Writer
The NI ELVISmx Digital Writer updates the NI myDAQ digital lines with user-specified digital
patterns. NI ELVISmx Digital Writer groups the I/O lines into ports through which data can be
written. You can write a 4-bit pattern (0 to 3 or 4 to 7) or an 8-bit pattern (0 to 7). You can also
manually create a pattern or select predefined patterns, such as ramp, toggle, or walking 1s. This
instrument can control a port of four or eight consecutive lines and either continually output a
pattern or just perform a single write.
The output of the NI ELVISmx Digital Writer stays latched until either another pattern is
generated, the lines it is using are configured for read, or the power is cycled on the NI myDAQ.
Figure 19. NI ELVISmx Digital Writer
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Example: Measuring a Signal Using the NI ELVISmx
Oscilloscope with NI myDAQ
Complete the following steps to measure a signal with the NI ELVISmx Scope.
Before opening an NI ELVISmx software instrument, make sure that the
myDAQ device is connected to the system and is ready to use. After the myDAQ is
connected to the system, the blue LED by the connector lights, indicating the device
is ready for use.
Note

1.

Connect the signal(s) you want to measure to the connector(s) on the side of the NI myDAQ
device.

2.

Launch the NI ELVISmx Scope from the NI ELVISmx Instrument Launcher.

3.

Click Run. You should see the signal in the Display Window.

4.

If necessary, adjust the controls to stabilize the signal in the graph. Adjust the Time/Div,
Vertical Position, Scale, and other controls as desired.
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Using NI myDAQ with LabVIEW
This section provides an overview of using NI myDAQ with LabVIEW.

NI ELVISmx Express VIs in LabVIEW
With NI ELVISmx, the NI myDAQ instruments have an associated LabVIEW Express VI.
Express VIs allow you to interactively configure the settings for each instrument. This enables
you to develop LabVIEW applications without extensive programming expertise. To access the
NI ELVISmx Express VIs, open a LabVIEW block diagram and select Measurement I/O»
NI ELVISmx from the function palette.
Table 4 shows the available NI ELVISmx Express VIs. Refer to the NI ELVISmx Help for more
information. To access this help file, go to Start»All Programs»National Instruments»
NI ELVISmx for NI ELVIS & NI myDAQ»NI ELVISmx Help.
Table 4. NI ELVISmx Express VIs for NI myDAQ

NI ELVISmx Express VI

—
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Example: Measuring Signals Using the NI ELVISmx
Oscilloscope Express VI with NI myDAQ
Complete the following steps to use the NI ELVISmx Oscilloscope to measure a signal.
For more information on grounding the signals, refer to the Connecting
Analog Input Signals section.
Note

1.

Launch LabVIEW.

2.

In the Getting Started window, click Blank VI. A blank VI opens. Select Window»Show
Block Diagram to open the VI block diagram.
You can also open the block diagram from the VI front panel by pressing
<Ctrl-E>.
Tip

3.

Right-click the block diagram window to open the Functions palette, then select
Measurement I/O»NI ELVISmx to open the ELVISmx Express VI palette.

4.

Select the NI ELVISmx Oscilloscope Express VI from the VI palette and place it on the
block diagram. The NI ELVISmx Oscilloscope configuration window opens.

5.

Connect the signal(s) you want to measure to the connector(s) on the side of the NI myDAQ
device.

6.

On the Configuration tab of the configuration window, select to measure Channel 0,
Channel 1, or both. Select the Channel 0 Enable checkbox to measure Channel 0. Select
the Channel 1 Enable checkbox to measure Channel 1. Select the Channel 0 Enable and
Channel 1 Enable checkboxes to measure both channels.

7.

If necessary, click the Auto Setup button to automatically configure the oscilloscope
parameters to acquire the signal, or explicitly set the Sample Rate and Record Length.
You can also configure the measurement to acquire N samples or acquire Continuously.
If necessary, adjust the controls to stabilize the signal in the graph.

8.

Click OK on the configuration window front panel.
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9.

On the block diagram, right-click the Channel 0 output terminal and select Create»Graph
Indicator from the menu. This creates a Graph Indicator on the VI front panel to display
the signal data. Repeat this step for Channel 1 if you configured the NI ELVISmx
Oscilloscope Express VI to enable Channel 1.

10. Click the Run button to begin acquiring the measurement. You should see the signal(s) in
the graphs on the VI front panel.

1

1

Run Button
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Using NI-DAQmx with NI myDAQ
NI myDAQ is supported by NI-DAQmx, and therefore you can program it using the DAQ
Assistant Express VI. Figure 20 shows the DAQ Assistant Express VI.
Figure 20. DAQ Assistant Express VI

Note

In NI-DAQmx, DIO <0..7> appear as P0.<0..7>.

Furthermore, you can use NI-DAQmx to program some of the available general AI, AO, and
timing functionality of the device. Refer to the NI ELVISmx Help and NI-DAQmx Help for more
information.
Note When using NI-DAQmx to read the audio channels, you must manually
change the voltage range to ±2 V from the default voltage range of ±10 V. The ±10 V
range is not supported by NI-DAQmx and will cause an NI-DAQmx error, but it will
not cause the user to receive corrupt data.

Example: Measuring Audio Pass-Through in LabVIEW
with NI myDAQ
This example covers the simultaneous acquisition of input signals and generation of output
signals using the DAQ Assistant in LabVIEW. This example forms the foundation for audio
signal processing experimentation.
1.

Launch LabVIEW.

2.

In the Getting Started window, click Blank VI. A blank VI opens. Select Window»Show
Block Diagram to open the VI block diagram.

3.

Locate the DAQ Assistant Express VI by right-clicking the block diagram window and
selecting Measurement I/O»NI DAQmx»DAQ Assist from the Functions palette.

4.

Place the DAQ Assistant Express VI on the block diagram. The DAQ Assistant Create
New Express Task configuration window opens.
You can also use the Quick Drop dialog box to locate the DAQ Assistant
Express VI. Select View»Quick Drop or press the <Ctrl-Space> keys to display this
dialog box.

Tip

5.

In the DAQ Assistant configuration window, select Acquire Signals»Analog Input, and
click Voltage to select a Voltage task.

6.

In the Supported Physical Channels window, select audioInputLeft from under the Devx
(NI myDAQ) option. You can also press <Ctrl> while clicking audioInputRight to select
both channels.
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7.

Click Finish to exit the Create New Express Task dialog.

8.

On the Configuration tab of the DAQ Assistant front panel window, configure voltage
channel 0 by selecting Voltage_0 in the Channel Settings pane, and setting Max to 2 and
Min to -2 in the Signal Input Range pane. Repeat this step for voltage channel 1 if you
configured the task for two channels.

9.

Under Timing Settings, set Acquisition Mode to Continuous Samples. Enter 5000 in
Samples to Read, and 40000 in Rate (Hz).

10. Click OK to exit the DAQ Assistant configuration front panel. The VI builds. Click No on
the Confirm Auto Loop Creation dialog box that displays.
11. Place another DAQ Assistant Express VI to the right of the previously configured DAQ
Assistant Express VI on the block diagram. The DAQ Assistant Create New Express Task
configuration window opens.
12. In the DAQ Assistant configuration window, select Generate Signals»Analog Output,
and click Voltage to select a Voltage task.
13. In the Supported Physical Channels window, select audioOutputLeft from under the
Devx (NI myDAQ) option. You can also press <Ctrl> while clicking audioOutputRight to
select both channels.
14. Click Finish to exit the Create New Express Task dialog.
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15. On the Configuration tab of the DAQ Assistant front panel window, configure voltage
channel 0 by selecting VoltageOut_0 in the Channel Settings pane, and setting Max to 2
and Min to -2 in the Signal Output Range pane. Repeat this step for voltage channel 1 if
you configured the task for two channels.
16. Under Timing Settings, set Generation Mode to Continuous Samples.

17. Click OK to exit the DAQ Assistant configuration front panel. The VI builds. Click No on
the Confirm Auto Loop Creation dialog box that displays.
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18. Wire the data output terminal of the first DAQ Assistant Express VI to the data input
terminal of the second DAQ Assistant Express VI.
19. Add a While Loop to the block diagram by right-clicking the block diagram window and
selecting Programming»Structures»While Loop from the Functions palette, and drag
out a rectangular region to enclose both DAQ Assistant Express VIs.
20. Add a STOP control to your block diagram by right-clicking the STOP button and selecting
Create Control.

21. Click the Run button

to test your LabVIEW application.

22. Attach a music player to the AUDIO IN 3.5 mm jack, and connect speakers to the AUDIO
OUT jack. You should hear the music on the speakers. If you do not hear sound, test the
speakers on the music player to make sure there is sound playing and that the speakers are
functioning properly.
This example provides the basis for audio measurement. Experiment further by placing digital
signal processing steps such as filters between the input and output.
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Texas Instruments Components in NI myDAQ
Integrated circuits supplied by Texas Instruments form the power and analog I/O subsystems of
NI myDAQ. Figure 2 depicts the arrangement and function of the NI myDAQ subsystems.
Table 5 lists all of the Texas Instruments components used in NI myDAQ. Visit www.ti.com
to see the specifications documents for each of the components in the design.
Table 5. Texas Instruments Components in NI myDAQ
Texas Instruments
Integrated Circuit
(IC)

Part Number

Description

Current-Limited
Power Distribution
Switch

TPS2553

This is used for applications where precision current
limiting is required or heavy capacitive loads and short
circuits are encountered.

Regulator

TPS61170

This is a monolithic high-voltage boost regulator with
an integrated 1.2 A, 40 V power MOSFET.

Regulator

TPS62007

Regulator

TPS62003

The TPS6200x devices are a family of low-noise
synchronous step-down DC-DC converter that is
ideally suited for systems powered from a one-cell
Li-ion battery or from a two- to three-cell NiCd,
NiMH, or alkaline battery.

LDO Regulator

TPS71501

LDO Regulator

TPS76433

Digital Isolator

ISO7241A

Shift Register

SN74AHC595

Switch

TS5A3159

These are low-dropout (LDO) voltage regulators,
offering the benefits of low noise, low-dropout
voltage, low-power operation, and miniaturized
packages.
This is a quad-channel digital isolator with multiple
channel configurations and output enable functions.
This device contains an 8-bit serial-in, parallel-out
shift register that feeds an 8-bit D-type storage register.
This is a single-pole double-throw (SPDT) analog
switch designed to operate from 1.65 V to 5.5 V.

Operational Amplifier

OPA171

This is a single-supply, low-noise operational
amplifier.

Operational Amplifier

TL062C

This JFET operational amplifier features high input
impedance, wide bandwidth, high slew rate, low input
offset, and input bias currents.

ADC

ADS8319

This is a 16-bit, 500-kS/s analog-to-digital converter.

DAC

DAC8551

This is a small, low-power, voltage output, 16-bit
digital-to-analog converter (DAC).

Reference

REF3025

This is a precision, low power, low voltage dropout
voltage reference available in a small SOT23-3.
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Table 5. Texas Instruments Components in NI myDAQ (Continued)
Texas Instruments
Integrated Circuit
(IC)

Tristate Buffer

Part Number

SN74AHCT1G125

Description

This is a single bus buffer gate/line driver with
three-state output.

Voltage Supervisor

TPS3809

This is a supervisory circuit that provides circuit
initialization and timing supervision, primarily for
DSPs and processor-based systems.

Comparator

TLV3491

This is a push-pull output comparator that features a
fast 6 µs response time and <1.2 µA (max) nanopower
capability, allowing operation from 1.8 V-5.5 V.

Operational Amplifier

TLE2082

This is an operational amplifier more than double the
bandwidth and triple the slew rate of the TL07x and
TL08x families of BiFET operational amplifiers.

Operational Amplifier

OPA1642

This is a JFET-input, ultra-low distortion, low-noise
operational amplifier, fully specified for audio
applications.

TPA6110A2

This is a stereo audio power amplifier packaged in an
eight-pin PowerPAD™ MSOP package capable of
delivering 150 mW of continuous RMS power per
channel into 16 Ω-loads.

Audio Amplifier

Buffer

SN74AUP1G17

Switch

TS12A44514

This is a low-power Schmitt-Trigger buffer.
This is a low on-state resistance quad SPST CMOS
analog switch.

Resource Conflicts
Table 6 summarizes the resource conflicts you might encounter if you run certain NI myDAQ
circuitry simultaneously.
To use the information in Table 6, find the instrument you want to use in the left column. That
row lists all the functions that are resource conflicts. If the intersecting box contains an —, you
can use those functions simultaneously without any conflicts.
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Table 6. NI myDAQ Resource Conflicts
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— = No resource conflict.
x = Conflict exists.

Additional Resources
The following resources contain information you might find helpful.

Related Documentation
The following documents contain information that you may find helpful as you use this manual.

NI myDAQ
NI myDAQ Specifications—This document lists the hardware specifications for your
NI myDAQ device.

NI ELVISmx
NI ELVISmx Help—This help file contains information about the NI ELVISmx software,
including information on using NI ELVISmx software instruments and NI ELVISmx Express
VIs. To access this help file, go to Start»All Programs»National Instruments»NI ELVISmx
for NI ELVIS & NI myDAQ»NI ELVISmx Help.

LabVIEW
•

LabVIEW Help—This help file includes information about LabVIEW programming
concepts, step-by-step instructions for using LabVIEW, and reference information about
LabVIEW VIs, functions, palettes, menus, and tools.

Multisim
•

Getting Started with NI Circuit Design Suite—Follow the tutorial in Chapter 2 of this
manual to familiarize yourself with the basics of Multisim.

•

Multisim Help File—This help file describes Multisim and its functions. It is organized
based on the stages of circuit design, and explains all aspects of Multisim in detail. This
help file also provides detailed information about using NI ELVISmx instruments in
Multisim. The NI ELVISmx information is also found in the NI Multisim for Education
manual.

NI-DAQmx
NI-DAQmx Help—This help file explains key NI-DAQmx concepts, describes how to create
common applications, and details device-specific information needed to use NI-DAQmx.

Other Resources
•

ni.com/mydaq—Contains product information, support information, and helpful links to

tutorials, examples, curriculum, videos, and more.
•

ni.com/lv101—Contains learning modules for basic Core LabVIEW Concepts,

hardware connections, and other measurement and analysis tasks.
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Common Terms and Acronyms
Table 7 lists some commonly used acronyms in data acquisition and measurement.
Table 7. Commonly Used Acronyms

Acronym

Definition

Description

ADC

Analog-to-digital
converter

Device that converts analog signals into digital
data.

AI/AO

Analog input/analog
output

A continuous signal that conveys data from
physical phenomena such as temperature, strain,
pressure, sound, or light.

DAC

Digital-to-analog
converter

Device that converts digital code into analog
signals.

DAQ

Data acquisition

Measuring an electrical or physical phenomenon
such as voltage, current, or temperature using a
combination of hardware and software.

DIO

Digital input/output

A non-continuous signal that conveys data in
digits or pulses that can be logged as digital data
or converted into an analog signal for viewing.

GND

Ground

The ground or earth reference in a circuit.

MIO

Multifunction
input/output

The collective term for multiple measurements
types, such as AI, AO, DIO, GND, and power
signals.

PFI

Programmable Function
Interface

A signal that can be configured for different uses,
such as a digital input, a digital output, a timing
input, or a timing output.

VI

Virtual Instrument

A software program and hardware device that
work together to create a user-defined
measurement system.
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Warranty
For customers other than private individual users in the EU—The NI myDAQ is warranted
against defects in materials and workmanship for a period of one year from the date of shipment,
as evidenced by receipts or other documentation. National Instruments will, at its option, repair
or replace equipment that proves to be defective during the warranty period. This warranty
includes parts and labor.
For private individual users in the EU—Based on your statutory rights, National Instruments
will—through its distributor—cure defects in materials and workmanship within two years from
delivery.
For support, visit the Worldwide Offices section of ni.com/niglobal to access the branch
office websites, which provide up-to-date (distributor) contact information.

Worldwide Support and Services
The National Instruments website is your complete resource for technical support. At ni.com/
support you have access to everything from troubleshooting and application development
self-help resources to email and phone assistance from NI Application Engineers.
Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, and
other services.
Visit ni.com/register to register your National Instruments product. Product registration
facilitates technical support and ensures that you receive important information updates from NI.
National Instruments corporate headquarters is located at 11500 North Mopac Expressway,
Austin, Texas, 78759-3504. National Instruments also has offices located around the world. For
telephone support in the United States, create your service request at ni.com/support or dial
1 866 ASK MYNI (275 6964). For telephone support outside the United States, visit the
Worldwide Offices section of ni.com/niglobal to access the branch office websites, which
provide up-to-date contact information, support phone numbers, email addresses, and current
events.
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